Error with Mudlet update

Post Reply
Sivan
Posts: 49
Joined: Tue Jun 23, 2009 3:54 am

Error with Mudlet update

Post by Sivan »

Was there an update pushed out for Mudlet?

I am using Ubuntu 10.04 and got a message that there was an update, but when I try and install it, I get the following error.

E: /var/cache/apt/archives/liblua5.1-rex-pcre0_2.4.0-1_i386.deb: trying to overwrite '/usr/lib/lua/5.1/rex_pcre.so', which is also in package lrexlib1 0

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: Error with Mudlet update

Post by tsuujin »

Vadi was playing with that earlier.

User avatar
Vadi
Posts: 4763
Joined: Sat Mar 14, 2009 3:13 pm

Re: Error with Mudlet update

Post by Vadi »

:oops:

Removing lrexlib1 will allow Mudlet to update. Meanwhile, I'll push another update that specifies lrexlib1 as a conflict, so it should be automatically removed if you want to update.

Sivan
Posts: 49
Joined: Tue Jun 23, 2009 3:54 am

Re: Error with Mudlet update

Post by Sivan »

Vadi wrote::oops:

Removing lrexlib1 will allow Mudlet to update. Meanwhile, I'll push another update that specifies lrexlib1 as a conflict, so it should be automatically removed if you want to update.
When I try and remove lrexlib1 it says Mudlet will also be removed.

User avatar
Vadi
Posts: 4763
Joined: Sat Mar 14, 2009 3:13 pm

Re: Error with Mudlet update

Post by Vadi »

That's right, because the current one depends on it. Next version though hates lrexlib1, and it'll use another lib. So uninstall lrexlib1 (and mudlet), and then install it again (which will install the next version)

Sivan
Posts: 49
Joined: Tue Jun 23, 2009 3:54 am

Re: Error with Mudlet update

Post by Sivan »

Well, I did what you suggested, and on the re-install I still got an error.

E: /var/cache/apt/archives/liblua5.1-rex-pcre0_2.4.0-1_i386.deb: trying to overwrite '/usr/lib/lua/5.1/rex_pcre.so', which is also in package lrexlib1 0

Sivan
Posts: 49
Joined: Tue Jun 23, 2009 3:54 am

Re: Error with Mudlet update

Post by Sivan »

I got it fixed. I had to unmark a previously selected file that was marked for install, then remove Mudlet and lrexlib1 and then re-install Mudlet.

Sivan
Posts: 49
Joined: Tue Jun 23, 2009 3:54 am

Re: Error with Mudlet update

Post by Sivan »

Thanks for the help.

User avatar
Vadi
Posts: 4763
Joined: Sat Mar 14, 2009 3:13 pm

Re: Error with Mudlet update

Post by Vadi »

Sent another update to PPAs that should resolve this and provide a smoother upgrade.

Post Reply