Lua 5.3 released

A category for whatever! Can be Mudlet-related or offtopic.
Post Reply
User avatar
keneanung
Site Admin
Posts: 93
Joined: Mon Mar 21, 2011 9:36 am
Discord: keneanung#2803

Lua 5.3 released

Post by keneanung » Tue Jan 13, 2015 9:45 am

The new lua 5.3 also has a UTF-8 support library. Maybe this would be a reason to upgrade?

http://www.lua.org/news.html

User avatar
Vadi
Posts: 4667
Joined: Sat Mar 14, 2009 3:13 pm

Re: Lua 5.3 released

Post by Vadi » Tue Jan 13, 2015 7:48 pm

Lua 5.1 also has UTF-8 support. Either solution will require work to add, but one will break a whole lot of scripts.

Getting your scripts broken or finding old amazing ones that no longer work isn't exactly a feature of a MUD client :)

User avatar
keneanung
Site Admin
Posts: 93
Joined: Mon Mar 21, 2011 9:36 am
Discord: keneanung#2803

Re: Lua 5.3 released

Post by keneanung » Tue Jan 13, 2015 7:53 pm

I haven't looked too deeply, but I didn't find too much that was incompatible. It was merely a suggestion and a hope this were things we could work around :P

dentin
Posts: 14
Joined: Sun Dec 01, 2013 8:19 pm

Re: Lua 5.3 released

Post by dentin » Thu Jan 15, 2015 6:22 pm

Pretty much no servers support unicode anyway, so it's not exactly high priority.

User avatar
SlySven
Posts: 918
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Lua 5.3 released

Post by SlySven » Sun Jan 18, 2015 11:48 pm

dentin wrote:Pretty much no servers support unicode anyway, so it's not exactly high priority.
English ones maybe but if we're aiming for World Domination we do have to handle all those fancy character them foreigners use. Besides how are you gonna send an insult in Klingon if you can not even write it out. :lol:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest