Help playing sound file using the 3.0.0 gamma version

Brynniel
Posts: 6
Joined: Sat Jan 10, 2015 7:29 pm

Help playing sound file using the 3.0.0 gamma version

Post by Brynniel »

Version: 3.0.0 gamma
OS: Windows 7

I am unable to play a sound from Mudlet and I believe this may be a bug. I first tried using the playSoundFile function. With this I have verified that the path to the sound is correct. I even copied the sound to C:\ and tried pointing playSoundFile there, and it didn't work. I've tried playing wav and mp3 formats.

Next I tried playing a sound file from a trigger, which gives a dialog and I browse to the sound file and select it. I have many other triggers that work.

Is this a known issue, or should I report it? Or did I miss something?

Thanks.

User avatar
Belgarath
Posts: 232
Joined: Fri Jul 26, 2013 7:19 am
Discord: macjabeth#2283

Re: Help playing sound file using the 3.0.0 gamma version

Post by Belgarath »

Might be a bug with Windows 7. I just tested it on 3.0.0 gamma in OSX Yosemite 10.10 and it played fine for me.

Played Sia - Chandelier in .mp3 format. 8-)

This might seem silly, but did you have your volume up?

User avatar
Vadi
Posts: 4826
Joined: Sat Mar 14, 2009 3:13 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by Vadi »

Does it work under 2.1 for you?

Brynniel
Posts: 6
Joined: Sat Jan 10, 2015 7:29 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by Brynniel »

It's okay, it's a fair question, but yes my sound is working since other apps can play music and whatnot and I hear it. I'll try it in 2.1 and see if it works.

Brynniel
Posts: 6
Joined: Sat Jan 10, 2015 7:29 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by Brynniel »

Vadi: I just tried playSoundFile in 2.1 and it works. Any ideas, or should I just wait for the next release :) ?

malaphus
Posts: 9
Joined: Mon Feb 01, 2010 11:47 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by malaphus »

Can also confirm, playSoundFile does not work for me in Windows 8.1.

Jaren
Posts: 21
Joined: Sun Nov 17, 2013 1:55 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by Jaren »

I am running Windows 7 Pro and 'playSoundFile()' works great for me in version 2.1 but it will not work at all in 3.0.0 gamma.

I found this old post about a workaround using gstreamer but I can't seem to get the correct syntax for a windows OS.
http://forums.mudlet.org/viewtopic.php?f=9&t=1506

Is there ANY way to play sounds in the newest version? I love all the new features that this new version has to offer but so many of my triggers rely on scripted sounds. Any help would be appreciated.

EDIT: Furthermore on 3.0.0 gamma, I also found that the normal 'play sound' button at the top right of a trigger no longer works and mudlet is not showing up in my windows sound mixer either.

User avatar
Vadi
Posts: 4826
Joined: Sat Mar 14, 2009 3:13 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by Vadi »

gstreamer is for Linux mainly.

Sound is broken in the 3.0 previews on WIndows, this is something are fixing.

User avatar
SlySven
Posts: 952
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Help playing sound file using the 3.0.0 gamma version

Post by SlySven »

Ah Vadi - don't forget sound in the 2.1 was using the Phonon library used with Qt4 but since Qt5 dropped using it we're using the QMultiMedia stuff. The underlying hardware support does not seem to be entirely complete - there could be one or two issues with the minGW support aparently:

"Overview of the current state of Qt Multimedia in Qt 5 and propose a roadmap for future releases:"
http://qt-project.org/wiki/Qt_Multimedia
Also:
http://qt-project.org/wiki/Qt_Multimedia_Backends

malaphus
Posts: 9
Joined: Mon Feb 01, 2010 11:47 pm

Re: Help playing sound file using the 3.0.0 gamma version

Post by malaphus »

Curious if there's any progress on this? A year seems like a long time =/

Post Reply