Install Error on Fedora 19

Post Reply
User avatar
Belgarath
Posts: 232
Joined: Fri Jul 26, 2013 7:19 am
Discord: macjabeth#2283

Install Error on Fedora 19

Post by Belgarath »

Hello! I just installed Fedora 19 on my desktop. I have been using Mudlet for a long time - it is my favourite MUD client!

However, after installing the linux 64-bit version, tried running the "Run Mudlet" binary and got no result. So I used the terminal and got this error:

[root@localhost bin]# ls
lfs.so libphonon.so.4.6.0 libQtOpenGL.so.4 luasql.so
libaudio.so.2 libpng12.so.0 libQtXml.so.4 mudlet
libc.so.6 libpthread.so.0 libsqlite3.so.0 mudlet-lua
liblua5.1.so.0 libQtCore.so.4 libsqlite3.so.0.8.6 rex_pcre.so
liblua5.1.so.0.0.0 libQtDBus.so.4 libstdc++.so.6 rex_pcre.so.2.4
libpcre.so.3 libQtGui.so.4 libyajl.so.1 run-mudlet.sh
libphonon.so.4 libQtNetwork.so.4 libzzip-0.so.13 zip.so
[root@localhost bin]# run-mudlet.sh
bash: run-mudlet.sh: command not found...
[root@localhost bin]# ./run-mudlet.sh
./mudlet: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory
[root@localhost bin]#


I am a complete newbie - Please help me, Mudlet Forum. You're my ONLY hope!

User avatar
Vadi
Posts: 4759
Joined: Sat Mar 14, 2009 3:13 pm

Re: Install Error on Fedora 19

Post by Vadi »

Is Mudlet available in your package manager? It looks like the generic linux installer cannot work on your system (there might be something I could do about this, but I can't guarantee it).

User avatar
kevutian
Posts: 217
Joined: Fri Aug 20, 2010 8:18 pm
Location: United Kingdom
Contact:

Re: Install Error on Fedora 19

Post by kevutian »

Don't run Mudlet as root.

You should be able to just symlink anything missing.

User avatar
Belgarath
Posts: 232
Joined: Fri Jul 26, 2013 7:19 am
Discord: macjabeth#2283

Re: Install Error on Fedora 19

Post by Belgarath »

Thank you for the responses! I talked to Vadi on the IRC channel. He said to post to the Fedora Forums and ask them for help. I've done that and one person has responded already. It didn't fix anything but hopefully more will respond.

I have tried yum installing missing packages but it hasn't made any progress. This is what I get now when trying to run Mudlet:

[boonie@localhost bin]$ ./run-mudlet.sh
./mudlet: /home/boonie/mudlet-2.1/bin/libc.so.6: version `GLIBC_2.17' not found (required by /lib64/libglib-2.0.so.0)
./mudlet: /home/boonie/mudlet-2.1/bin/libc.so.6: version `GLIBC_2.17' not found (required by /lib64/libdrm.so.2)

User avatar
Belgarath
Posts: 232
Joined: Fri Jul 26, 2013 7:19 am
Discord: macjabeth#2283

[SOLVED] Install Error on Fedora 19

Post by Belgarath »

All I had to do was remove the copy of libc it had inside the mudlet directory. After that, it worked like a charm!

Post Reply