Freezing, primarily in the script window (Mapper issue)

Post Reply
Sanaki
Posts: 110
Joined: Wed Mar 09, 2011 1:30 am

Freezing, primarily in the script window (Mapper issue)

Post by Sanaki » Tue Apr 23, 2013 9:31 pm

So as of a couple weeks ago I've had some horrible freezing issues in Mudlet, mostly in the script window. Any time I'd click an alias/trigger/script/etc, it'd take between 5-100 seconds to load up, depending on the size of the loading script, during which time the entirety of Mudlet was useless. Changing focus on the script window was usually a 5-10 second process. Typing at any decent pace also would cause the main window to freeze up until I stopped typing for a few seconds. Lots of irritation.

Eventually I backed up and just started deleting things from my profile until it stopped, until I stumbled upon the cause: the mudlet mapper. Omitting the createMapper line removed all my problems. And by relation, wiping every other script in my profile (including aliases/triggers/etc) did nothing to alleviate the issue.

Just to be safe, I checked a blank profile, not a thing in it, and opened the map. Same issue started up.

If anyone would like copies of files I have or anything of that nature to see if something went awry, let me know. Right now, I can't play with the map open, and I'd love a fix.

EDIT: anyone wondering about system specs, Windows 7 64-bit, here's the exact laptop I'm running on.

Edit 2: Starting to get reports from a couple others of having this same issue and just not bothering to report it. Also, haven't tried a fresh install to see if it's present on that. I don't have time to do so at the moment, but I'll check later on.

User avatar
Vadi
Posts: 4721
Joined: Sat Mar 14, 2009 3:13 pm

Re: Freezing, primarily in the script window (Mapper issue)

Post by Vadi » Tue Apr 23, 2013 9:49 pm

Does it happen with any kind of map, official or crowdmap?

Sanaki
Posts: 110
Joined: Wed Mar 09, 2011 1:30 am

Re: Freezing, primarily in the script window (Mapper issue)

Post by Sanaki » Tue Apr 23, 2013 9:53 pm

It happens with or without any actual map loaded, in and out of Achaea, even on a blank profile not connected to any server.

User avatar
Vadi
Posts: 4721
Joined: Sat Mar 14, 2009 3:13 pm

Re: Freezing, primarily in the script window (Mapper issue)

Post by Vadi » Tue Apr 23, 2013 10:00 pm

I'm not sure what the cause of that would be yet then.

Sanaki
Posts: 110
Joined: Wed Mar 09, 2011 1:30 am

Re: Freezing, primarily in the script window (Mapper issue)

Post by Sanaki » Tue Apr 23, 2013 10:05 pm

Let me know if you think of anything. As of right now, only two others have mentioned having the issue and I can't remember who one was. The other I've confirmed was also on Win7 64-bit Home Premium, in case it's somehow related, but I'm rather certain it doesn't affect everyone on that specific version. I'll post here again if I come up with some new brilliant theory, but for now I'm just clueless.

Jor'Mox
Posts: 1099
Joined: Wed Apr 03, 2013 2:19 am

Re: Freezing, primarily in the script window (Mapper issue)

Post by Jor'Mox » Tue Apr 23, 2013 11:23 pm

I definitely have encountered a similar experience. Immediately upon installing a generic mapper script that someone had posted here on the forums, I started having full crashes every 20-30 minutes. Sometimes more frequently than that. It persisted through three different versions of Mudlet, and through me deleting the script itself. I ultimately had to delete my entire Mudlet folder to get rid of it. Running Mac OS X 10.8.3.

Sanaki
Posts: 110
Joined: Wed Mar 09, 2011 1:30 am

Re: Freezing, primarily in the script window (Mapper issue)

Post by Sanaki » Thu Apr 25, 2013 3:22 am

So I was playing without my map running, the crowdmap auto-updated, userwindow map opened, and... nothing. The issue's gone. Which makes little sense to me since it wasn't tied to any specific profile.

I... I've got nothing. Hopefully it was just a passing glitch?

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 4 guests