What happens with "<" and ">" ?

Post Reply
Rutseg
Posts: 6
Joined: Tue Mar 27, 2012 3:51 pm

What happens with "<" and ">" ?

Post by Rutseg »

The "<" and ">" characters are not being showed correctly in the mud output.
Example:
say test->this() and-<this()
Rutseg kindly says: test-this() and-
/d/orgoth]

This is anoying me so much as makes imposible ot read LPC code online using mudlet.
I've checked the triggers and scripts but there's nothing suspicious there. Indeed I only have the preinstalled ones.
Don't seem to be a server problem as it reads OK when using the telnet client either with UTF-8 or ISO-8559-1 character sets.

I installed Mudlet from the Ubuntu repository last week.
In Help>About it says is version: Mudlet 2.0 June 12, 2011
In title it says: Mudlet 2.0-test4 10-25-2011

PD: It might be addressed before, but the search engine doesn't accept single character searches.

User avatar
Vadi
Posts: 4867
Joined: Sat Mar 14, 2009 3:13 pm

Re: What happens with "<" and ">" ?

Post by Vadi »

Try enabling the special option of 'force MXP off'

Rutseg
Posts: 6
Joined: Tue Mar 27, 2012 3:51 pm

Re: What happens with "<" and ">" ?

Post by Rutseg »

Done it, but problem persists, even after restarting mudlet and reconnecting.
Weird enough I tried another MUD and works fine... and if I access the previous with telnet client it also works properly.
Somehow it is the interaction rlmud.org - mudlet...

User avatar
Vadi
Posts: 4867
Joined: Sat Mar 14, 2009 3:13 pm

Re: What happens with "<" and ">" ?

Post by Vadi »

Can't test, my Spanish isn't so good...

Rutseg
Posts: 6
Joined: Tue Mar 27, 2012 3:51 pm

Re: What happens with "<" and ">" ?

Post by Rutseg »

I've checked that even if MXP off is checked in profile preferences, the first line on connecting to the MUD says:
<MXP support enabled>

Can someone else confirm this? you may need to scroll up on connection as it appears over the:
LPmud version: FluffOS v2.22-RL.
Mudlib version: Pusa-v2.1
in the title screen.

Rutseg
Posts: 6
Joined: Tue Mar 27, 2012 3:51 pm

Re: What happens with "<" and ">" ?

Post by Rutseg »

In fact, checking the source code, ctelnet.cpp, line 684, no profilepreference option seems to be checked.

Code: Select all

          if( option == MXP ) // MXP support
          {
            sendTelnetOption( TN_WILL, 91 );
            mpHost->mpConsole->print("\n<MXP support enabled>\n");
            break;
          }

Rutseg
Posts: 6
Joined: Tue Mar 27, 2012 3:51 pm

Re: What happens with "<" and ">" ?

Post by Rutseg »

Checking against Discworld MUD, which also runs FlufflOS, the only difference is:

RLMud: TELNET IAC DO ATCP
Discworld: TELNET IAC DO GMCP

The complete negotiation:

Code: Select all

OK we are willing to enable telnet option TERMINAL_TYPE
OK we are willing to enable telnet option NAWS
MCCP v2 negotiated!
SORRY, we are NOT WILLING to enable this telnet option.
TELNET IAC DO ATCP
server sends telnet option terminal type
checking mccp start seq...
MCCP version 1 starting sequence
-1,-6,86,-1,-16
But, if I check has_gmcp(find_player("rutseg")) it returns 1, what means my server is probably thinking I'm using GMCP while mudlet does not. So, that means it is not a mudlet but a FlufflOS problem and I'm writting in the wrong forum ;)

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: What happens with "<" and ">" ?

Post by tsuujin »

Rutseg wrote:In fact, checking the source code, ctelnet.cpp, line 684, no profilepreference option seems to be checked.

Code: Select all

          if( option == MXP ) // MXP support
          {
            sendTelnetOption( TN_WILL, 91 );
            mpHost->mpConsole->print("\n<MXP support enabled>\n");
            break;
          }
looks like that actually comes from the cTelnet::processTelnetCommand() function, and "option" is one of the input arguments. It would theoretically be checked against your profile settings elsewhere.

User avatar
Heiko
Site Admin
Posts: 1548
Joined: Wed Mar 11, 2009 6:26 pm

Re: What happens with "<" and ">" ?

Post by Heiko »

You need to restart Mudlet after setting the "force MXP off" option. However, this only means that Mudlet tries to disable MXP on the server by telling the server that we do not support MXP via telnet options. If the server still uses MXP sequences, Mudlet will still translate them and thus cause < etc. to be ommitted from output unless they are properly escaped according to the MXP specs.
For more technical information send me an email -> Mudlet about dialog.

Post Reply