Getting a mapping script to work

Post Reply
Posts: 1
Joined: Tue Mar 13, 2012 6:29 pm

Getting a mapping script to work

Post by RiverRaid »

Hi. I'm new to MUDs, new to Mudlet. I want to play WoTmud. Tried zmud and fiddled with mapper, got it mostly working, but could not find many scripts for it and it costs more than I'm willing to pay for what it is and how much I intend to use it. Found Mudlet and it looks very suitable so far.

I'm on WinXP and downloaded Mudlet 2.0-test4b. I know this is beta, but I read someplace that the public release doesn't have a mapper.

I found the WoTmud mapper script and downloaded it. However I can't figure out how to use it. This seems like super basic info to me yet I can't find any instructions to set it up. I've looked in the Mudlet documentation, the mapper script download page and replies therein, searched the forums, browsed each forum topic under Help and How-to sections.

I downloaded the xml file, and in Mudlet I clicked Scripts button and clicked Import, then selected the WoTmud mapper xml. It shows up on the list under generic_mapper_script. I opened the mapper and receive a warning that "no mapping script found". I closed this warning window. The mapper portion of the Mudlet window shows a big red dot in the middle and some stats. Moving around in the MUD doesn't map any rooms. I tried disabling generic_mapper_script, saving the profile, re-enabling generic_mapper_script, uninstalling WoTmud mapper in the Package Manager then reinstalling it through that instead of importing in the Scripts window... Testing after each modification to no avail.

Maybe the script is broken, or doesn't work with this version. Maybe I'm missing something obvious right under my nose, but I'm not a complete idiot. I can't believe this has never been brought up or occurred to anyone to provide some instructions. In the WoTmud mapper download page someone asked for these basic instructions, and the reply was that "it starts mapping automatically", but that isn't true for me. If someone can point out where I can find this info or explain what I need to do I'd appreciate it.

Thank you.

Posts: 33
Joined: Tue Dec 01, 2009 4:40 am

Re: Getting a mapping script to work

Post by Sheia »

I'm not very familiar with that mapper script or your particular MUD so I'm not sure I can help much, however have you tried looking at theWiki? That link will take you to the mapper functions list in particular.

You seem to be using a mapper script created by an individual for their own use, not something the makers of Mudlet have produced, which may work fine, but be very tailored to that individual. If they provide no documentation, then you may simply have to figure it out yourself, or ask them directly for more info. I realize it can be frustrating to get something working when there is little to no documentation, but this is someone else's baby and it is on them to document it. Is the debug window showing any errors when you try moving from room to room?

If I get a chance I'll try the script out myself and see if I can get it working. I assume you did all the little quarks and reviewed all the known bugs that are listed in this thread?

Post Reply