Crash while in editor

Post Reply
takilara
Posts: 2
Joined: Tue Jul 28, 2020 10:23 pm

Crash while in editor

Post by takilara »

I have fairly recently converted to Mudlet from another mud client, and I'm graduately moving all my settings over.

I have one repeatedly occurring issue, that i hope someone can help with. Namely, every now and then, Mudlet will crash when i enter, or navigate the editor. Including Alt-tab to an already opened settings editor.

This seems to happen more frequently if i have been running the application for a long time, though this is just a hunch
Exception says it is an 0xc0000005 issue in Qt5Widgets.dll (exception included below)


Context:
  • the mud i play, allow scripting, Mudlet is often on for days or weeks without getting restarted
  • the mud i play allow multiplaying, i have 8 chars running the same profile (copy's). I use Module manager to include a synced file for each of aliases, scripts, triggers, timers and macros. (these files are then version controlled with git)
  • Mudlet is running on a windows 10 virtual machine
  • I do have a custom mapping script, (adding this info due to similar earlier 3.3 crash), but error does not seem to be related to mapper, but rather the settings editor.
  • I generally open the settings editor by clicking the "Scripts" button on my main profile, then leave it open (alt tab'ing) back to main window
  • Mudlet is rock solid during mud gameplay, and i have not yet experienced a single crash unless i switch to the settings editor.
I found some older posts about similar issue in Mudlet 3.3, but nothing that seemed recent enough.

I hope you can help :)

regards


Exception:
Faulting application name: Mudlet.exe, version: 4.9.1.0, time stamp: 0x5ee84bbd
Faulting module name: Qt5Widgets.dll, version: 5.13.2.0, time stamp: 0x5db2f24d
Exception code: 0xc0000005
Fault offset: 0x00016de3
Faulting process id: 0x242c
Faulting application start time: 0x01d66445b620d19d
Faulting application path: C:\Users\xxxx\AppData\Local\Mudlet\app-4.9.1-ptbb9e6fdb7\Mudlet.exe
Faulting module path: C:\Users\xxxxx\AppData\Local\Mudlet\app-4.9.1-ptbb9e6fdb7\Qt5Widgets.dll
Report Id: 997d74eb-bea7-4a25-b8d4-680d6566f9b5
Faulting package full name:
Faulting package-relative application ID:

User avatar
SlySven
Posts: 964
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Crash while in editor

Post by SlySven »

You say you are running it on a virtual machine - as a pure matter of curiosity what is the host OS? {I mean it is a little easier to debug on a Linux platform than a Windows one at the moment}.

Are you in a position where you would be willing (and able) to compile Mudlet yourself? I do run a Windows development environment as well as a Linux and FreeBSD ones but it is a little bit of a work in progress at the moment { https://wiki.mudlet.org/index.php?title ... rnative.29 } and hasn't made it completely into the current project structure, but since it is MSYS2/Mingw-w64 based one it is fairly simple to do debug Windows builds (which yield a lot more debugging information than our current release {significantly faster but without debugging information} builds like what you are currently having problems in!)

One thought - you say you are multi-playing 8 characters - how much of a load on your system is that? Do you still have a reasonable amount of memory and CPU load to spare?

takilara
Posts: 2
Joined: Tue Jul 28, 2020 10:23 pm

Re: Crash while in editor

Post by takilara »

Thanks for the response :)
The Host is ESXi 6.0 running on a HP Proliant DL380G7. Cpu's are fairly old (2 x X5680)
Guest is Windows 10, x64, configured with 4 cores, 1 socket, 8gb ram

I looked at the utilization while the Bot is running my 8 chars, and the load seems ok:
- CPU utilization on the guest: Total 3-18%, evenly over all cores, Mudlet: 1.5-3%
- RAM utilization on the guest: Total 43%, Mudlet: 674MB
- Mudlet uptime, approx 6 days
- Windows uptime, 20days, 11 hours

Note, Yesterday, i did go "hands on", and i did do script changes, without encountering any crash when entering the editor. (Closed Editor on Character 3, opened Editor using "Scripts" button on Character 1), so this does not happen always, and does not seem to be related to uptime of Mudlet.

As the exception seem to be tied to a Qt memory allocation issue in the dll file, i suspect maybe the issue will only happen on Windows. I can setup an Ubuntu or Mint machine to see if i have the same issues there using the same settings. I'll have to make some small adaptions as I am writing out some telemetry files using windows paths, but that will be trivial to fix.

I have some but limited experience with C++ and QT, but I have some, I see you have excellent resources on compiling, so I can try to setup for that. Did you specifically mean to compile on Windows for Windows to build debug build?

Thanks again, and best regards
shot2.png
shot2.png (42.98 KiB) Viewed 42 times
shot1.png
shot1.png (30.69 KiB) Viewed 42 times

Post Reply