Page 2 of 2

Re: Howto: Compile Mudlet on Gentoo.

Posted: Wed May 15, 2013 2:40 pm
by kevutian
Ahh, this is awesome. This will save so much time. I always hated doing this build on Gentoo, heh.

Thanks for posting this!

Re: Howto: Compile Mudlet on Gentoo.

Posted: Mon May 27, 2013 9:57 am
by kevutian
Just a heads up. This overlay is failing on Sabayon (Portage tree is fully synced with Gentoo and the world is up to date as of today).

It's whining about a missing Phonon. I went ahead and built Phonon manually though the issue persists. I ended up just building almost everything manually.

Hopefully this is confined to Sabayon, but I see no reason at this stage why this would be the case given the build environment similarities.

Re: Howto: Compile Mudlet on Gentoo.

Posted: Sun Jul 28, 2013 7:25 pm
by abeing
Thank you for making this overlay. I have successfully installed the overlay and set my package use (I think), but when I do an emerge mudlet I get the following error:

src/glwidget.h:24:39: fatal error: QtOpenGL/qgl.h: No such file or directory

I am not sure which package QtOpenGL/qgl.h comes from, but it might be that you are missing a dependency? Or I am missing a use flag? (I have both qt4 and openql use flags in my make.conf).

Re: Howto: Compile Mudlet on Gentoo.

Posted: Sun Jul 28, 2013 8:44 pm
by Vadi
I think you need to install OpenGL Qt module.

Re: Howto: Compile Mudlet on Gentoo.

Posted: Sun Jul 28, 2013 9:17 pm
by kevutian
Yeah, sudo emerge -al qt-opengl should fix you up there. Hopefully I am wrong, but I seem to recall I had to overlay that, too.

Re: Howto: Compile Mudlet on Gentoo.

Posted: Tue May 06, 2014 1:27 pm
by fetaera
*** UPDATED May 2014 ***

Having decided to play around with Gentoo again, I've gone ahead and update this thread with a current guide for building with Qt5.3.

NOTE: This method will build the latest Mudlet git sources from Chris' repository, uses no overlays and relies solely on emerging from portage or via source packages from respective websites where portage packages are either missing or of a not recent enough version.

Steps:

Create build directory:

mkdir -p ~/projects && cd ~/projects



Emerge 'working' sources from the portage tree:

emerge -av git boost hunspell glu opengl lua
Note: To install a language of your choice in Hunspell: echo "app-text/hunspell linguas_de" >> /etc/portage/package.use
Note: For QuaZip, add >=sys-libs/zlib-1.2.8-r1 minizip to /etc/portage.package.use



Pull and build 'other' packages:

LibZip: wget http://www.nih.at/libzip/libzip-0.11.2.tar.gz && tar -xvzf libzip-0.11.2.tar.gz && cd libzip-0.11.2 && ./configure && make && sudo make install
(Not sure why it derps on one and not the other, but: sudo ln -s /usr/local/lib/libzip/include/zipconf.h /usr/local/include zipconf.h)

LibYAJL: git clone git://github.com/lloyd/yajl && cd yajl && ./configure && make && sudo make install



Install Qt development package:

wget http://download.qt-project.org/developm ... 0-beta.run && chmod +x qt* && ./qt*



Get Mudlet source:

git clone https://github.com/Chris7/Mudlet2.git



Make a small change to src.pro. (Basically, just s/llua5.1/llua)



Build Mudlet:

cd Mudlet2 && ~/Qt5.3.0/5.3/gcc/bin/qmake && make

Re: Howto: Compile Mudlet on Gentoo.

Posted: Tue May 06, 2014 1:40 pm
by fetaera
For the Lua runtime stuff, just use LuaRocks.