Issues with latest git.

Post Reply
fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Issues with latest git.

Post by fetaera » Fri Dec 06, 2013 9:26 pm

There seem to be countless issues with the latest git. All seem wholly related to the current QT bugs. Has anybody filed against these yet?

User avatar
chris
Posts: 493
Joined: Fri Jun 17, 2011 5:39 am

Re: Issues with latest git.

Post by chris » Sun Dec 08, 2013 12:35 am

Could you be more specific? I build against Qt 5.1.1 just fine (on both windows 7 x64/ubuntu 13.10)

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Issues with latest git.

Post by fetaera » Sun Dec 08, 2013 12:58 am

Yep, sure thing.

Qt5.1.1 on Debian Sid.

Issues: The map window fails to show any rooms. (Once you load the git version one time, it happens and is persistent even when loading back into 2.1) - You're required to rm the map stuff from the profile dir.

Artifacts on border-image UI elements. (Slight, but annoying).

Segfault on clicking a UI element with setLabelOnEnter() assigned with no associated function defined.

A couple of times, my UI has just point blank failed to load, returning a nil error. (Can mostly ignore this for now as I can't give any further info at this time as it seems to be rare and I failed to note the error). (Error was a -Lua- function being nil, not a user defined one).

Images just randomly failing to display. Either they show all the time or simply never show at all. Affects just some of them, not all and again, seems extremely random.

Those are the ones I can remember off the top of my head. I'll get a bit more info on here when I find the other issues.

User avatar
Vadi
Posts: 4724
Joined: Sat Mar 14, 2009 3:13 pm

Re: Issues with latest git.

Post by Vadi » Sun Dec 08, 2013 7:13 am

Not experiencing any of them...

User avatar
chris
Posts: 493
Joined: Fri Jun 17, 2011 5:39 am

Re: Issues with latest git.

Post by chris » Sun Dec 08, 2013 1:58 pm

I'd say do a clean build of Qt and use my git repo instead of SF (https://github.com/Chris7/Mudlet2/tree/mudletDev). SF is usually a bit behind on bug resolution.

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Issues with latest git.

Post by fetaera » Sun Dec 08, 2013 5:19 pm

Can I assume you're building against 5.1 now? Granted, it's been a while, but the last time I used your branch, we were still on 4.8.

Thanks. I'll give it a go shortly.

User avatar
chris
Posts: 493
Joined: Fri Jun 17, 2011 5:39 am

Re: Issues with latest git.

Post by chris » Sun Dec 08, 2013 5:21 pm

Yes, I use 5.1.1

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest