Build Mudlet on RK3399 SBC

Post Reply
ecloud
Posts: 8
Joined: Sat May 02, 2020 11:46 am

Build Mudlet on RK3399 SBC

Post by ecloud »

Hi
I'm trying to build Mudlet on FriendlyARM Nano-PC T4 which is a RK3399 ARM64 SBC.
I'm following the guide of RPi on the wiki.
And finally I got the error msg that:

Code: Select all

Project ERROR: Mudlet requires Qt 5.11 or later
My qt5 is 5.9.5
And I have tried to specify -qt=qt5, but nothing changed.

Code: Select all

pi@AstroT4:~/swork/Mudlet/build$ export QT_SELECT=qt5
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later
pi@AstroT4:~/swork/Mudlet/build$ export QT_SELECT=qt5-aarch64-linux-gnu
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later
pi@AstroT4:~/swork/Mudlet/build$ export QT_SELECT=5
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later
pi@AstroT4:~/swork/Mudlet/build$ export QT_SELECT=qt5-aarch64-linux-gnu
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake -qt=5 ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later
pi@AstroT4:~/swork/Mudlet/build$ qtchooser -list-versions
4
5
default
qt4-aarch64-linux-gnu
qt4
qt5-aarch64-linux-gnu
qt5
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake -qt=qt5 ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later
pi@AstroT4:~/swork/Mudlet/build$ WITH_UPDATER=NO WITH_3DMAPPER=NO qmake -qt=qt5-aarch64-linux-gnu ../src/mudlet*pro
Project ERROR: Mudlet requires Qt 5.11 or later

User avatar
Vadi
Posts: 4852
Joined: Sat Mar 14, 2009 3:13 pm

Re: Build Mudlet on RK3399 SBC

Post by Vadi »

That's right, your Qt of 5.9 is less than what Mudlet needs - 5.11. Look into upgrading it! Latest is 5.14.

User avatar
SlySven
Posts: 974
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Build Mudlet on RK3399 SBC

Post by SlySven »

FTR although Qt 5.9 is a Long Term Support (LTS) version 5.9.9 is End of Support at the end of this month (2020-05-31). We are using feature that are just not available prior to 5.11 I am afraid. Qt 5.12 (currently 5.12.8) is the next long-term support version and that will be supported by Qt until 2021-12-05 - ideally the company who produces the software images will update the version that they distribute - I note that the current version (optimised for the display hardware is currently 5.10 not 5.9 according to http://wiki.friendlyarm.com/wiki/index. ... pplication ) so you may not be too far off getting to 5.11.

The only alternative is to try and work out what features require 5.11 and to bypass the version check in the ./src/mudlet.pro file - it will break, I would pretty much expect that compilation of Mudlet will fail - you will just have to see if you can put in extra code to get around the features that were obsoleted/done away with by 5.11. You may be able to get some clues by looking back through the git history of the Mudlet code to see what got changed around the time that the minimum version was increased to that (for a while it WAS 5.9 IIRC).

Post Reply