[available] GMCP in Mudlet

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 4:25 am

Vadi wrote:Add -fPIC to CFLAGS (or however the compiler flags variable is called)
I'm not having any luck with this. The make files do specify a CFLAGS variable, but adding -fPIC to it does nothing at all and I still get the same error.

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 4:29 am

scratch that. a MAKE CLEAN fixed that problem. Now I get this:

tsuujin@localhost:~/lrexlib-2.4.0/lrexlib-2.4.0$ make build_pcre
make -C src/pcre -f rex_pcre.mak
make[1]: Entering directory `/home/tsuujin/lrexlib-2.4.0/lrexlib-2.4.0/src/pcre'
gcc -W -Wall -g -I/usr/include/lua5.1 -DREX_OPENLIB=luaopen_rex_pcre -DREX_LIBNAME=\"rex_pcre\" -fPIC -c -o lpcre.o lpcre.c
In file included from lpcre.c:78:
../algo.h: In function ‘check_ud’:
../algo.h:102: warning: cast to pointer from integer of different size
gcc -W -Wall -g -I/usr/include/lua5.1 -DREX_OPENLIB=luaopen_rex_pcre -DREX_LIBNAME=\"rex_pcre\" -fPIC -c -o lpcre_f.o lpcre_f.c
gcc -W -Wall -g -I/usr/include/lua5.1 -DREX_OPENLIB=luaopen_rex_pcre -DREX_LIBNAME=\"rex_pcre\" -fPIC -c -o ../common.o ../common.c
ar rcu librex_pcre.a lpcre.o lpcre_f.o ../common.o
ld -o rex_pcre.so.2.4 -shared lpcre.o lpcre_f.o ../common.o -lpcre -llua
ld: cannot find -llua
make[1]: *** [rex_pcre.so] Error 1
make[1]: Leaving directory `/home/tsuujin/lrexlib-2.4.0/lrexlib-2.4.0/src/pcre'
make: *** [build_pcre] Error 2
2

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 4:45 am

ok, got it to compile finally

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 5:00 am

Ugh... ok. I give up. Now I can't get the gmcp branch to find pcre.h, which is in /usr/include

Edit: looking a little harder, I'm not certain that it's the header it can't find, because the error message isn't really that specific.

Edit again: downloaded and compiled pcre-8.10, and installed g++ which set the compiler flags for me. Below message is the most recent even after the pcre install.

tsuujin@localhost:~/gmcp$ ./build.sh
4 coress found using them to build Mudlet\n
J=4
make: *** No rule to make target `clean'. Stop.
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:70 (MESSAGE):
Could NOT find PCRE (missing: PCRE_LIBRARIES)
Call Stack (most recent call first):
/home/tsuujin/gmcp/cmake/FindPCRE.cmake:75 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:164 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
Last edited by tsuujin on Sat Jun 26, 2010 5:22 am, edited 1 time in total.

naftali
Posts: 138
Joined: Wed Jan 20, 2010 8:42 pm

Re: GMCP in Mudlet

Post by naftali » Sat Jun 26, 2010 5:20 am

Any chance of seeing any binaries (I'm obvs particularly interested in a mac one) made that support GMCP?

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 5:41 am

Ok then! I found the project file for QT and just loaded it up in the SDK and built it from there, which worked fine!

First time I started it up was great. I logged in, my system loaded perfectly, everything was good. I turned on GMCP and closed the client, then logged back in.

Now the game connects, I'm prompted for my user name, which I key in. When I hit enter the client freezes entirely. I also can't seem to turn GMCP off, because it refuses to save.

Edit: I managed to turn GMCP off by letting the connection lag out and trying again. I logged in with no problems, logged back out, turned on GMCP and tried again, to another freeze.

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 5:45 am

[ERROR]: UNKNOWN Host Package Element:name= "" text: ";"
[ERROR]: UNKNOWN Host Package Element:name= "commandSeperator" text: ""
pattern= "FG8BG0"
[OK] color pattern initialized: "FG8BG0"
pattern= "FG13BG0"
[OK] color pattern initialized: "FG13BG0"
GMCP enabled
MCCP v2 negotiated!
checking mccp start seq...
MCCP version 1 starting sequence
-1,-6,86,-1,-16
COMPRESSION START sequence found
starting ZLIB decompression. ***resizing commandline: _height= 36 height()= 31

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 5:50 am

Hmm, let me be a bit more specific:

Mudlet itself doesn't freeze. I can scroll the window, access all of my combat system, change settings, whatever.

When I attempt to send my character name, however, nothing else is received from the game. It's like it's simply lagging horribly, but nothing comes through no matter how long I wait, and it happens every single time I have GMCP enabled.

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: GMCP in Mudlet

Post by tsuujin » Sat Jun 26, 2010 6:04 am

For testing purposes, I opened up aetolia rather than midkemia, and aetolia logged in just fine.

Widjet
Posts: 30
Joined: Thu Apr 22, 2010 1:43 am

Re: GMCP in Mudlet

Post by Widjet » Sat Jun 26, 2010 6:17 am

With a bit of work, I managed to build this version too.

I can log into MKO just fine, but display(gmcp) gives me an empty table. So either gmcp isn't enabled yet for MKO, or something isn't working right.

Edit: Okay, somehow the GMCP option disabled itself. Now I'm getting the same behaviour as Tsuujin (freezing).

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests