1.0.6 question

Post Reply
User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

1.0.6 question

Post by tsuujin »

I'm currently using ubuntu, and would very much like to use the 1.0.6 version of mudlet (because my combat system uses ATCP heavily and I understand it's already implemented in the new version.

However, when I download the latest source, cmake complains that Tarea.cpp is being requested and not supplied. Sure enough, CMakeLists.txt asks for Tarea.cpp, which is not supplied in the source directory.

I took the line out, for curiosity, and found that TMap.h and TMap.cpp are also being listed but not supplied.

What do I need to do to get ahold of the missing files?

User avatar
Vadi
Posts: 4854
Joined: Sat Mar 14, 2009 3:13 pm

Re: 1.0.6 question

Post by Vadi »

Use qmake to compile it (run qmake in src/ folder, also install and setup Qt 4.6 SDK)

Those files are probably part of the mapper which is unfinished and not in git yet.

User avatar
Heiko
Site Admin
Posts: 1548
Joined: Wed Mar 11, 2009 6:26 pm

Re: 1.0.6 question

Post by Heiko »

You cannot currently test pre 1.0.6 on Linux because the code on git is *very* outdated. Currently, your only option is to use the latest Windows snapshot available on sourceforge.net.
Git won't be updated for a while, I'm sorry.

User avatar
tsuujin
Posts: 695
Joined: Fri Feb 26, 2010 12:59 am
Location: California
Contact:

Re: 1.0.6 question

Post by tsuujin »

Ah, I see.

Well, I suppose I'll stick with MUSH then. I'm excited about mudlet, but rewriting my system to pull stats from alternate sources would really be a step backwards.

Thanks!

guy
Posts: 26
Joined: Wed Mar 03, 2010 5:41 am
Location: Seattle

Re: 1.0.6 question

Post by guy »

When can we expect an update to GIT? (I am running pre1.0.6 on linux btw).

User avatar
Heiko
Site Admin
Posts: 1548
Joined: Wed Mar 11, 2009 6:26 pm

Re: 1.0.6 question

Post by Heiko »

Coming up soon.

guy
Posts: 26
Joined: Wed Mar 03, 2010 5:41 am
Location: Seattle

Re: 1.0.6 question

Post by guy »

Wonderful! And to clarify, by pre1.0.6 you aren't referring to the git version which calls itself 1.0.6?

Post Reply