Mudlet 3.0.0-alpha

User avatar
Vadi
Posts: 4941
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi »

Beta is now out. Please re-test and report any issues still present from 3.0.0-alpha. Thanks everyone!

User avatar
SlySven
Posts: 996
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Mudlet 3.0.0-alpha

Post by SlySven »

Siduri wrote:Can we get a confirmation that the bug where 3.0.0 would randomly delete the content of scripts is done and gone?
When I had installed it, my scripts stopped working, then I went and checked: they were still there, and enabled, but the code box was empty. I fixed it, saved it, saved the profile. A couple of minutes later, it was gone again.
I think it's been fixed but the overall program logic for the editor is due for a rewrite for other reasons if I remember correctly bug 1269582.

Sanaki
Posts: 110
Joined: Wed Mar 09, 2011 1:30 am

Re: Mudlet 3.0.0-alpha

Post by Sanaki »

Unless I'm mistaken, prior Mudlet versions shipped with dictionaries. The beta doesn't appear to, and requires a restart before imported dictionaries will function.

User avatar
Vadi
Posts: 4941
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi »

Which installer are you having the difficulty with?

Please note that the thread for the beta is here.

zilar
Posts: 2
Joined: Wed Sep 24, 2014 4:19 pm

Re: Mudlet 3.0.0-alpha

Post by zilar »

Hi everybody,

I'm trying to get to compile the mudlet in macos, but get stucket in the following error, and googling it I could not get a solution:

MacBook:src brak$ make
/Applications/Xcode.app/Contents/Developer/usr/bin/g++ -c -pipe -g -O3 -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-parameter -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk -std=c++0x -mmacosx-version-min=10.6 -Wall -W -fPIE -DQT_OPENGL_LIB -DQT_MULTIMEDIA_LIB -DQT_WIDGETS_LIB -DQT_UITOOLS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/local/include -I../../Qt/5.3/ios/mkspecs/macx-g++ -I. -I. -I/usr/include/lua5.1 -Iirc/include -I../../Qt/5.3/ios/include -I../../Qt/5.3/ios/include/QtOpenGL -I../../Qt/5.3/ios/include/QtMultimedia -I../../Qt/5.3/ios/include/QtWidgets -I../../Qt/5.3/ios/include/QtUiTools -I../../Qt/5.3/ios/include/QtNetwork -I../../Qt/5.3/ios/include/QtGui -I../../Qt/5.3/ios/include/QtCore -I. -I. -o TConsole.o TConsole.cpp
warning: unknown warning option '-Wno-unused-local-typedefs'
[-Wunknown-warning-option]
In file included from TConsole.cpp:24:
In file included from ./TConsole.h:37:
In file included from ./TCommandLine.h:32:
In file included from ./Host.h:51:
In file included from ./TArea.h:33:
In file included from ./TRoomDB.h:26:
In file included from ./TMap.h:35:
In file included from ./glwidget.h:24:
In file included from ../../Qt/5.3/ios/include/QtOpenGL/qgl.h:47:
../../Qt/5.3/ios/include/QtGui/qopengl.h:70:12: fatal error:
'OpenGLES/ES2/gl.h' file not found
# include <OpenGLES/ES2/gl.h>
^
1 warning and 1 error generated.
make: *** [TConsole.o] Error 1

Can anyone help me?

zilar
Posts: 2
Joined: Wed Sep 24, 2014 4:19 pm

Re: Mudlet 3.0.0-alpha

Post by zilar »

Hi all I cannot get compiling on macos, can anyone help me? this the error I got ( openGL is installed ... )

MacBook-de-Iker-Gonzalez-Alonso:src brak$ make
/Applications/Xcode.app/Contents/Developer/usr/bin/g++ -c -pipe -g -O3 -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-parameter -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk -std=c++0x -mmacosx-version-min=10.6 -Wall -W -fPIE -DQT_OPENGL_LIB -DQT_MULTIMEDIA_LIB -DQT_WIDGETS_LIB -DQT_UITOOLS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/local/include -I../../Qt/5.3/ios/mkspecs/macx-g++ -I. -I. -I/usr/include/lua5.1 -Iirc/include -I../../Qt/5.3/ios/include -I../../Qt/5.3/ios/include/QtOpenGL -I../../Qt/5.3/ios/include/QtMultimedia -I../../Qt/5.3/ios/include/QtWidgets -I../../Qt/5.3/ios/include/QtUiTools -I../../Qt/5.3/ios/include/QtNetwork -I../../Qt/5.3/ios/include/QtGui -I../../Qt/5.3/ios/include/QtCore -I. -I. -o TConsole.o TConsole.cpp
warning: unknown warning option '-Wno-unused-local-typedefs'
[-Wunknown-warning-option]
In file included from TConsole.cpp:24:
In file included from ./TConsole.h:37:
In file included from ./TCommandLine.h:32:
In file included from ./Host.h:51:
In file included from ./TArea.h:33:
In file included from ./TRoomDB.h:26:
In file included from ./TMap.h:35:
In file included from ./glwidget.h:24:
In file included from ../../Qt/5.3/ios/include/QtOpenGL/qgl.h:47:
../../Qt/5.3/ios/include/QtGui/qopengl.h:70:12: fatal error:
'OpenGLES/ES2/gl.h' file not found
# include <OpenGLES/ES2/gl.h>
^
1 warning and 1 error generated.
make: *** [TConsole.o] Error 1

User avatar
Vadi
Posts: 4941
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi »

It looks like you are missing OpenGL headers?

ajsdkt
Posts: 2
Joined: Sat Nov 22, 2014 8:18 pm

Re: Mudlet 3.0.0-alpha

Post by ajsdkt »

I do not know if it is intentional or not, but the two boxes that I used most for instant input for toggle buttons are not there anymore (but my current button still works. Although I do not know how I would edit it, or make more without the boxes.)

Image

User avatar
SlySven
Posts: 996
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Mudlet 3.0.0-alpha

Post by SlySven »

Erm, yeah it is a known issue Bug 1417243 and is something that will be fixed before the proper release of 3.0.0 is made.

Post Reply