Mudlet 3.0.0-alpha

User avatar
Omni
Posts: 131
Joined: Fri Feb 12, 2010 10:26 am

Re: Mudlet 3.0.0-alpha

Post by Omni »

(At least) one of my function scripts seems to have been cleared, with 0 code in the code box, yet the function is still present and working in mudlet.

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Mudlet 3.0.0-alpha

Post by fetaera »

I have to say, the changes to the includes is rather profound. Compilation time is considerably faster.

Kelvin
Posts: 4
Joined: Sun Sep 14, 2014 3:24 am

Re: Mudlet 3.0.0-alpha

Post by Kelvin »

Looks like the Mac OS version crashes during startup. Running Mac OS 10.9.4. Not sure how to get a stack trace to you.

I had ran Mudlet 2.1 on this machine previously.

icesteruk
Posts: 287
Joined: Sun Jan 20, 2013 9:16 pm

Re: Mudlet 3.0.0-alpha

Post by icesteruk »

I download it on windows 7 and seems, It loads in full screen mode. even the full screen mode button gives me full screen.

User avatar
Vadi
Posts: 4759
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi »

Kelvin wrote:Looks like the Mac OS version crashes during startup. Running Mac OS 10.9.4. Not sure how to get a stack trace to you.

I had ran Mudlet 2.1 on this machine previously.
Okay, I suspected there was going to be something suspicious about a size reduction from 28mb to 5mb on the Mac installer. I think the Qt libraries didn't get bundled - I'll redo the installer tonight.

Kelvin
Posts: 4
Joined: Sun Sep 14, 2014 3:24 am

Re: Mudlet 3.0.0-alpha

Post by Kelvin »

OK, ping me and I'll test again.

User avatar
Vadi
Posts: 4759
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi »

New Mac installer up, it's file name is Mudlet_3.0.0-alphab.dmg when you download it.

Thanks everyone for having a look, I'll verify and file the issues tonight.

Kelvin
Posts: 4
Joined: Sun Sep 14, 2014 3:24 am

Re: Mudlet 3.0.0-alpha

Post by Kelvin »

It loaded this time, thanks!

User avatar
Belgarath
Posts: 232
Joined: Fri Jul 26, 2013 7:19 am
Discord: macjabeth#2283

Re: Mudlet 3.0.0-alpha

Post by Belgarath »

Same here! Cheers for the quick fix :)

As I go through, I'll edit this post with any errors I run into.
I seem to have a bunch of missing startup modules though (didn't have this prob in 2.1).
Code: [show] | [select all] lua
[ ERROR ] - Cannot find Lua module rex_pcre.
            Some functions may not be available.
            Lua error:[string "require "rex_pcre""]:1: module 'rex_pcre' not found:
                    no field package.preload['rex_pcre']
                    no file './rex_pcre.lua'
                    no file '/usr/local/share/lua/5.1/rex_pcre.lua'
                    no file '/usr/local/share/lua/5.1/rex_pcre/init.lua'
                    no file '/usr/local/lib/lua/5.1/rex_pcre.lua'
                    no file '/usr/local/lib/lua/5.1/rex_pcre/init.lua'
                    no file './rex_pcre.so'
                    no file '/usr/local/lib/lua/5.1/rex_pcre.so'
                    no file '/usr/local/lib/lua/5.1/loadall.so'
[  OK  ]  - Lua module zip loaded.
[ ERROR ] - Cannot find Lua module lfs (Lua File System).
            Probably will not be able to access Mudlet Lua code.
            Lua error:[string "require "lfs""]:1: module 'lfs' not found:
                    no field package.preload['lfs']
                    no file './lfs.lua'
                    no file '/usr/local/share/lua/5.1/lfs.lua'
                    no file '/usr/local/share/lua/5.1/lfs/init.lua'
                    no file '/usr/local/lib/lua/5.1/lfs.lua'
                    no file '/usr/local/lib/lua/5.1/lfs/init.lua'
                    no file './lfs.so'
                    no file '/usr/local/lib/lua/5.1/lfs.so'
                    no file '/usr/local/lib/lua/5.1/loadall.so'
[ ERROR ] - Cannot find Lua module luasql.sqlite3.
            Database support will not be available.
            Lua error:[string "luasql = require "luasql.sqlite3""]:1: module 'luasql.sqlite3' not 
found:
                    no field package.preload['luasql.sqlite3']
                    no file './luasql/sqlite3.lua'
                    no file '/usr/local/share/lua/5.1/luasql/sqlite3.lua'
                    no file '/usr/local/share/lua/5.1/luasql/sqlite3/init.lua'
                    no file '/usr/local/lib/lua/5.1/luasql/sqlite3.lua'
                    no file '/usr/local/lib/lua/5.1/luasql/sqlite3/init.lua'
                    no file './luasql/sqlite3.so'
                    no file '/usr/local/lib/lua/5.1/luasql/sqlite3.so'
                    no file '/usr/local/lib/lua/5.1/loadall.so'
                    no file './luasql.so'
                    no file '/usr/local/lib/lua/5.1/luasql.so'
                    no file '/usr/local/lib/lua/5.1/loadall.so'
[ ERROR ] - LuaGlobal.lua compile error - please report!
            Error from Lua: cannot open mudlet-lua/lua/LuaGlobal.lua: No such file or directory

User avatar
Vadi
Posts: 4759
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi »

Anyone else getting this on a Mac?

Post Reply