Mudlet 3.0.0-alpha

Post Reply
User avatar
Vadi
Posts: 4720
Joined: Sat Mar 14, 2009 3:13 pm

Mudlet 3.0.0-alpha

Post by Vadi » Sun Sep 14, 2014 8:06 am

Mudlet 3.0.0-alpha is here! This is an alpha release - that is, a preview of what Mudlet 3.0 will look like. Please be aware that there may be bugs and other issues in this preview release - we are publishing it so we can locate any such issues. If you run into anything, please post them here.

[/size]

[/size]

Please provide all feedback and problem reports on 3.0.0-alpha here! Feature requests can be done in our dedicated thread.

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Mudlet 3.0.0-alpha

Post by fetaera » Sun Sep 14, 2014 9:15 am

Finally! I've been using git for a long time now and can honestly say 3.0 is absolutely outstanding.

That said, I do have one small issue with how looping aliases are now handled. Assuming I am understanding this correctly, should a user make a change and attempt to save the change, they will basically lose all changes in the alias? Might it be better to just force the alias state to off should a loop be detected rather than have them lose any code?

All said and done, thanks for all the hard work over the last 2 years.

User avatar
Vadi
Posts: 4720
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi » Sun Sep 14, 2014 9:44 am

Only the 'substitution' field should be.

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Mudlet 3.0.0-alpha

Post by fetaera » Sun Sep 14, 2014 9:58 am

Ahh, great. Should be fine then. Thanks.

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Mudlet 3.0.0-alpha

Post by fetaera » Sun Sep 14, 2014 11:11 am

Only a small issue but after make installing, the path for LuaGlobal seems off. Works fine when executed from the src folder, though.

User avatar
Vadi
Posts: 4720
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.0.0-alpha

Post by Vadi » Sun Sep 14, 2014 11:17 am

You should use run-mudlet.sh or the 'Run Mudlet' desktop shortcut to launch Mudlet using the generic Linux installer.

fetaera
Posts: 191
Joined: Sat Aug 03, 2013 7:00 pm

Re: Mudlet 3.0.0-alpha

Post by fetaera » Sun Sep 14, 2014 12:47 pm

Oh? When I was compiling, it seemed to indicate make install was working now.

i.e.
martin@bawbag:~/projects/mudlet_git/Mudlet/src$ /home/martin/Qt5.3.1/5.3/gcc/bin/qmake
Project MESSAGE: mudlet will be installed to /usr/local/bin...
Project MESSAGE: Lua files will be installed to /usr/local/share/mudlet/lua...
Project MESSAGE: Geyser lua files will be installed to /usr/local/share/mudlet/lua/geyser...
Disregard then. Sorry.

User avatar
Belgarath
Posts: 232
Joined: Fri Jul 26, 2013 7:19 am
Discord: macjabeth#2283

Re: Mudlet 3.0.0-alpha

Post by Belgarath » Sun Sep 14, 2014 3:39 pm

Yay! *rapes the download link*

EDIT: Apparently I can't run this new version on the MAC i'm using... Just another reason to add to my "why I HATE MACS" list :evil:. Running on version 10.6.8 btw.

Will see if I can update to Mavericks..

Updated to Mavericks but still getting errors :(

This is the feedback it gives:
Code: [show] | [select all] lua
Process:         Mudlet [1118]
Path:            /Volumes/VOLUME/Mudlet.app/Contents/MacOS/Mudlet
Identifier:      com.yourcompany.Mudlet
Version:         ???
Code Type:       X86-64 (Native)
Parent Process:  launchd [233]
Responsible:     Mudlet [1118]
User ID:         508

Date/Time:       2014-09-14 21:34:51.348 +0100
OS Version:      Mac OS X 10.9.4 (13E28)
Report Version:  11
Anonymous UUID:  7AE33A08-B92F-93D9-3327-9312B12B68F5


Crashed Thread:  0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /usr/local/lib/libzzip-0.13.dylib
  Referenced from: /Volumes/VOLUME/Mudlet.app/Contents/MacOS/Mudlet
  Reason: image not found

Binary Images:
    0x7fff6e77c000 -     0x7fff6e7af817  dyld (239.4) <042C4CED-6FB2-3B1C-948B-CAF2EE3B9F7A> /usr/lib/dyld

Model: MacBookPro5,1, BootROM MBP51.007E.B06, 2 processors, Intel Core 2 Duo, 2.53 GHz, 4 GB, SMC 1.33f8
Last edited by Belgarath on Sun Sep 14, 2014 8:48 pm, edited 4 times in total.

User avatar
Omni
Posts: 131
Joined: Fri Feb 12, 2010 10:26 am

Re: Mudlet 3.0.0-alpha

Post by Omni » Sun Sep 14, 2014 3:42 pm

Few things I've noticed as I've started testing: selecting a variable with the checkbox, then clicking on another variable to view the value clears the checkbox for the previous one. Selecting multiple variables, say if you wanted to delete multiples does not work. There's also a random character issue, in that on the connection section when logging into Lusternia, the W in What is your password is replaced by a square. Small-ish issue, the icon gets broken it seems when this version is pinned to the taskbar. Loving a lot of the changes so far. Profile deletion still seems to be broken also.
Image

hogarius
Posts: 35
Joined: Mon Nov 21, 2011 8:35 pm

Re: Mudlet 3.0.0-alpha

Post by hogarius » Sun Sep 14, 2014 3:44 pm

Triggers are not responding to tab characters (\t) in a Perl reg-ex pattern specification.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests