Mudlet 3.3.1 is available!

Post Reply
User avatar
Zaphob
Posts: 104
Joined: Wed May 09, 2012 8:07 am
Location: mg.mud.de

Mudlet 3.3.1 is available!

Post by Zaphob » Sat Jul 08, 2017 6:41 am

Just one month after the previous major version change, now Mudlet 3.3.1 is here. This release brings in a whole new editor for Lua code, a completely revamped IRC window, and utf8 in Lua!



Please provide all feedback and problem reports on 3.3.1 here! Feature requests can be done in our dedicated thread.

Slayd
Posts: 102
Joined: Mon Jul 25, 2011 4:57 am

Re: Mudlet 3.3.1 is available! Profiles not saved

Post by Slayd » Sat Jul 15, 2017 7:37 pm

3.3.1 totally smoked the problem I was having with small type in the editor! Well done!

I am still having problems with lost Profiles when I create a new one. The default profile on creation has the three aliases, echo, runLua, and deleteOldProfiles. However these and any folders/items I create are lost when I close mudlet and return later.

I always select Save when I close mudlet. I've also started routinely clicking on SaveProfile after I have saved a particular item (alias, trigger, script et al) that I just created or updated. Everything is gone when I next connect to that profile.

I can see xml files in my ~/.config/mudlet/profiles/XXX/current folders, so I know there's not a file save problem there.

I'm using mudlet on a MacPro OSX Sierra 10.12.5. I've attached the latest profile saved
Attachments
15-07-2017#12-24-51.xml
(18.46 KiB) Downloaded 211 times

Jayden
Posts: 3
Joined: Sun Apr 17, 2016 7:13 pm

Re: Mudlet 3.3.1 is available!

Post by Jayden » Tue Aug 01, 2017 2:40 am

The new editor features in 3.3.1 are delightful! I spend much, much less time tabbing out to Sublime Text since it was introduced.

However, there is one nasty problem I've run into: The new editor seems to hate keyboard layouts with an AltGr key, rejecting any inputs made with it. I'm on a Finnish keyboard; backslashes, brackets, tildes, vertical pipes are all entered with AltGr key combinations - probably obvious how Lua could be tough without these! They worked perfectly fine in previous versions, and continue to in external programs. Inputting these characters still works in every other area of Mudlet, including when editing the trigger lines themselves - it is only in the new editor where these commands fail.

Edit: Alt codes (LAlt+KP60 for < for example) do not work either. AltGr and Alt key combinations both fail only within the editor.
Last edited by Jayden on Thu Aug 03, 2017 5:01 am, edited 1 time in total.

User avatar
Vadi
Posts: 4646
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.3.1 is available!

Post by Vadi » Tue Aug 01, 2017 4:41 am

Sorry about the problem! Does https://github.com/edbee/edbee-lib/issues/47 sound like what you're having?

Jayden
Posts: 3
Joined: Sun Apr 17, 2016 7:13 pm

Re: Mudlet 3.3.1 is available!

Post by Jayden » Wed Aug 02, 2017 8:53 pm

Yes, that's the exact same issue I'm running into! Using Alt+Ctrl instead of AltGr does not work either, same as in the issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest