Mudlet 3.2 is available!

User avatar
Vadi
Posts: 4674
Joined: Sat Mar 14, 2009 3:13 pm

Re: Mudlet 3.2 is available!

Post by Vadi » Fri Jul 07, 2017 5:19 am

I can confirm the default scripts going away in 3.2 - could you file the issue at https://github.com/Mudlet/Mudlet ?

Same for small font size.

Slayd
Posts: 102
Joined: Mon Jul 25, 2011 4:57 am

Re: Mudlet 3.2 is available!

Post by Slayd » Wed Jul 19, 2017 12:00 am

Will do. It's occurring also in 3.3.1

User avatar
SlySven
Posts: 919
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Mudlet 3.2 is available!

Post by SlySven » Wed Jul 19, 2017 11:54 pm

If this is the same poster who filed Issue 1225 there is something screwing up the save file - whether there are other issues I'm not sure at this point...

Slayd
Posts: 102
Joined: Mon Jul 25, 2011 4:57 am

Re: Mudlet 3.2 is available!

Post by Slayd » Thu Jul 20, 2017 12:31 am

That ━━━━━━ is me :)

I tried to open the modified profile in Mudlet and I still am getting nothing saved. As I noted on the Isssue, the xml I extracted from the zip file had a datetime group from tommorow. 12:17am tomorrow


* Above censored by Administrator: there is no need to denigrate yourself here - if you feel the need to, please do so in private! * :P

Slayd
Posts: 102
Joined: Mon Jul 25, 2011 4:57 am

Re: Mudlet 3.2 is available!

Post by Slayd » Thu Jul 20, 2017 8:42 pm

I've worked with SlySven a bit on this problem through github.

I posted a saved profile, which SlySven (at lest I believe it was he who I exchanged emails with) found the file was corrupted. I used a 'fixed' profile xml file that he sent back to me, and the profile and all saved stuff loaded fine. I can now save, quit, restart and load and everything works fine ON THAT PROFILE.

I tested with another new profile, this time using the default 3Kingdom profile that comes with Mudlet. I had no problems with that profile.

I then created a new profile (using new profile) for a Mud called Ateraan. The problem returned. I lost all three aliases that come with a new profile and any Settings changes I made.

Could the problem be the artifact or template that is used when 'new profile' is filled in to enter a new Mud? I would bet money that if SlySven looked at this latest profile, he would find the same pattern of corruption.

User avatar
SlySven
Posts: 919
Joined: Mon Mar 04, 2013 3:40 pm
Location: Deepest Wiltshire, UK
Discord: SlySven#2703

Re: Mudlet 3.2 is available!

Post by SlySven » Tue Jul 25, 2017 4:52 am

I was the person you contacted! :D

Do you have that the saved profile (the ".dat" file) data from that 'new profile'? You can check whether it is valid XML by opening it in a web browser (or at least FireFox) this is how the "fixed" file and the original corrupted file looked like last time:
Screenshot_20170725_054104.png
Two webpages shown side-by-side showing difference in FireFox for a valid and damaged Mudlet profile saved .dat file

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 3 guests