Updating older maps

All and any discussion and development of the Mudlet Mapper.
Post Reply
User avatar
chris
Posts: 493
Joined: Fri Jun 17, 2011 5:39 am

Updating older maps

Post by chris »

I've noticed older maps can act funky. One instance is with special exits, an older map of mine seems to lack the room lock status. I thought the version control system in the restore/serialization would fix this upon saving of a map, but it doesn't seem to cover all the cases. Users who visit older profiles might get unexpected behavior from out of date maps. Has anyone else had similar issues with older maps on newer mudlet releases (aka my repo) where such a tool might be worthwhile?

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Updating older maps

Post by Vadi »

Older maps just didn't load for me, I had to re-download map mine - which won't be feasible for those who did their mapping. I'd say a tool would be definitely worthwhile.

User avatar
chris
Posts: 493
Joined: Fri Jun 17, 2011 5:39 am

Re: Updating older maps

Post by chris »

the exit lock was because adding special exits by default doesn't set the lock status, hence the funkyness. I defaulted it to unlocked exits in my repo. What map wasn't working for you

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Updating older maps

Post by Vadi »

Well try connecting to a default achaea.com profile on the latest published binary (not sf git, since it's been merged with your stuff), opening the mapper on it - it'll download a map, and then opening that map on current git. That doesn't seem to work.

Sidd
Posts: 20
Joined: Fri Mar 26, 2010 5:33 pm

Re: Updating older maps

Post by Sidd »

I installed test4 for windows and my custom map doesn't work at all, I can't find it in the slightest. None of the functions will bring it up, even trying to manually do centerview(1337) for example, returns nothing.

Not sure what to do

User avatar
Heiko
Site Admin
Posts: 1548
Joined: Wed Mar 11, 2009 6:26 pm

Re: Updating older maps

Post by Heiko »

Send me the latest version of your map by email (-> Mudlet about dialog for details).

User avatar
Heiko
Site Admin
Posts: 1548
Joined: Wed Mar 11, 2009 6:26 pm

Re: Updating older maps

Post by Heiko »

This is due to a bug in test4. I've uploaded test4b to fix this issue. https://sourceforge.net/projects/mudlet/files/

DevArrah
Posts: 51
Joined: Sat Oct 29, 2011 4:57 pm

Re: Updating older maps

Post by DevArrah »

4b still seems to have issues related to specialExits

specifically, the function AddSpecialExit. it cuts 1 character off the command

so AddSpecialExit(2,3"portal") ends up creating an exit "ortal". I checked out the code on repository and it looks like the issue TRooms.cpp on 299 (i'm pretty sure the cmd is supposed to be _cmd). I gamed the code a bit and realized if I did AddSpecialExit(2,3,"1portal") it would work.

I'm not sure if it's a side effect but getSpecialExits now returns {id, {command,'0}} instead of what's in the documentation of {id, command}

This behavior is also inconsistent with getSpecialExitsSwap which DOES return {command, id}... however, the command still have the 0 prepended to it

There's also related issues to getSpecialExits and getSpecialExitsSwap. Here's some sample output from test4b
Code: [show] | [select all] lua
addSpecialExit(3,2,"portal")
display(getSpecialExits(3))
display(getSpecialExitsSwap(3))
Code: [show] | [select all] lua
table {
  'north': 4
}
special exits:

table {
  2: table {
    'ortal': '0'
  }
}

table {
  '0ortal': 2
}

User avatar
chris
Posts: 493
Joined: Fri Jun 17, 2011 5:39 am

Re: Updating older maps

Post by chris »

In the topic with test4b I posted a fix for the exits. Also, getspecialexits is different because that's the version I changed to return the exit and lock status as tables

Post Reply