Swimming delay

All and any discussion and development of the Mudlet Mapper.
Post Reply
Daarknes
Posts: 4
Joined: Tue Mar 01, 2011 10:51 am

Swimming delay

Post by Daarknes »

Ok, I am sure this has probably been covered elsewhere, but I can't find it or figure out how to fix it. When I use the mapper to speed walk into a room you would have to swim too, it keeps triggerring off "There's water ahead of you. You'll have to swim in that direction to make it through." and spamming the "swim dir" command over and over with the effect that I never swim anywhere. At first I thought that just adding a delay to it would be sufficient, then I recalled that that delay needed would vary based on network latency. Is there away to have it trigger the swim command once, and then wait until it receives the new %gmcp.room.info to send the next command?


Actually, in general is there a way to make it check for that before it moves every time? Not sure if that would be desirable or not, but I can't see why not. Hell, even just having the option would be nice. I am not certain if there is a new config xml file for the mapper floating around. I downloaded on that was linked here on the forums, but it seems pretty dated. I am using the Mudlet 2.0 though, so I don't think that is the issue.

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Swimming delay

Post by Vadi »

I'm not sure what the conclusion of your post is, but yes, swimming does need fixing in the IRE mapper script.

Daarknes
Posts: 4
Joined: Tue Mar 01, 2011 10:51 am

Re: Swimming delay

Post by Daarknes »

Also the abort button on the map downloader pop-up window doesn't work.

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Swimming delay

Post by Vadi »

Yep.

csmall
Posts: 20
Joined: Wed Jan 12, 2011 9:36 pm

Re: Swimming delay

Post by csmall »

ive seen that too. must look pretty funny me flapping my arms around going nowhere. It's pretty annoying though.

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Swimming delay

Post by Vadi »

Nobody else sees the msg

csmall
Posts: 20
Joined: Wed Jan 12, 2011 9:36 pm

Re: Swimming delay

Post by csmall »

Vadi wrote:Nobody else sees the msg
Do you mean that
  • its not visible to other players when you are doing this; or
  • noone else is having this bug

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Swimming delay

Post by Vadi »

The first. Everyone has the problem.

Beliar
Posts: 19
Joined: Fri Apr 22, 2011 12:51 pm

Re: Swimming delay

Post by Beliar »

I fixed that locally be replacing the code in the "swim exit" trigger with this:
Code: [show] | [select all] lua
send("swim " .. speedWalkDir[speedWalkCounter], false)
mmp.pause("on")
tempTimer(2.5, [[mmp.pause("off")]])
It works well enough here, though one may have to test what delay works best for him.

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: Swimming delay

Post by Vadi »

This has been properly fixed in the latest update of the script. Thanks!

Post Reply