mapper slow?

All and any discussion and development of the Mudlet Mapper.
Post Reply
User avatar
Omit
Posts: 190
Joined: Sun Aug 01, 2010 10:54 pm
Location: Middle Earth
Contact:

mapper slow?

Post by Omit »

I have been working on my Lua scripting for the 3D mapper and I have noticed that the map renders slowly....
this in and of itself is not a major issue but.... it seems to slow down the output from the mud (or at least how quickly it is rendered). (Lag.... and it clears up if I close the map window)

I have had similar issues in the past with scripting but normally when it has some output to the main window.
Has anyone else experienced this?

User avatar
Vadi
Posts: 4940
Joined: Sat Mar 14, 2009 3:13 pm

Re: mapper slow?

Post by Vadi »

Not really, although the mapper does seem to use a bit of CPU when it's rendering. Perhaps it's not using the GPU or having to do a lot of calculations, I'm not sure - but as the code is still in development, it's definitely not fully optimized yet.

User avatar
Heiko
Site Admin
Posts: 1548
Joined: Wed Mar 11, 2009 6:26 pm

Re: mapper slow?

Post by Heiko »

The mapper is still in its infant stages and I've applied zero speed optimizations at this point. The mapper speed is fine for IRE area sizes, but most likely no good for a 1000x1000 grid map at this point. This, however, will be no problem whatsoever once the speed optimizations have been added.

At this point you have to reduce the area size by making up some virtual areas. Shouldn't be too much of a problem.

Post Reply