Page 1 of 2

Halp Raspberry Pi Linux Babby

Posted: Wed Aug 22, 2018 9:20 pm
by Ampersat
Hi, I'm interested in installing Mudlet on my Raspberry Pi 3B+ running RetroPie 4.4.

I've managed to untar the package (3.12.0), but I'm not sure how to go about launching the AppImage file that it extracts. I tried './Mudlet.AppImage' but I get '-bash: ./Mudlet.AppImage: cannot execute binary file: Exec format error' returned to me.

I know this is just the tip of the iceburg asking for help on such a small thing considering what I'm attempting to get into.
I'd just like to jump into one and play for a few minutes to get me pumped up about the whole thing.

The end goal is to be able to launch Mudlet with different scripts from Emulation Station that can automatically connect to a couple different games, ideally logging in for me, as I won't ever remember my passwords. Anyway, I'm sure I can struggle through some guides and wikis. The wiki looks robust, thanks for that! I appreciate you guys taking the time to read my dumb post.

Re: Halp Raspberry Pi Linux Babby

Posted: Thu Aug 23, 2018 5:20 pm
by Vadi
The AppImage won't run - it's not compilied for an ARM processor that the pi runs on. Can you install Mudlet from the software centre? Does it have one?

Re: Halp Raspberry Pi Linux Babby

Posted: Thu Aug 23, 2018 6:58 pm
by Ampersat
Oh, haha! Well then. Of course, I wasn't thinking...

Unfortunately, unless I overlooked it, it's not included in the GUI-accessible repositories. They list things under categories such as "optional" "experimental" etc. I'm guessing there's a way to get it via command line, but I'm pretty clueless when it comes to using apt-get. I pretty much just copy paste lines following guides.

I'm guessing I could also compile it? I mean, theoretically, provided someone held my hand.

Re: Halp Raspberry Pi Linux Babby

Posted: Thu Aug 23, 2018 7:10 pm
by Vadi
Does the tool have the ability to search? Installing from there is easiest.

Re: Halp Raspberry Pi Linux Babby

Posted: Tue Aug 28, 2018 3:20 pm
by Ampersat
Unfortunately, no. I've just been using TT++, as I easily found the install line on a set up page. I'd be happy to give Mudlet a try, as the UI seems really appealing, but I've been playing a regular commercial video game instead.

Re: Halp Raspberry Pi Linux Babby

Posted: Tue Aug 28, 2018 3:59 pm
by Vadi
No worries - if you'd like to compile it yourself, search for "compile mudlet", it will bring you to this page which has an explanation:

Re: Halp Raspberry Pi Linux Babby

Posted: Fri Aug 31, 2018 2:23 pm
by Ampersat
Hmm, just tried using the command provided for Debian Sid / 9 Stretch to install the required packages. I was hoping since the two seem to be identical that it might work for Raspian, which I know is built from Debian. Unfortunately, I saw it wasn't perfect.
'Reading state information... Done'
I have
'Note, selecting 'liblua5.1-0dev' instaed of 'liblua5.1-dev''
E: Unable to locate package libzip-dev
E: Unable to locate package lua-sql-sqlite3'
I'd like to avoid reloading my last image backup so I figured I'd post here asking for more help. :D

As a side note, I gave Mudlet a try on my laptop just to stoke the flames of my budding interest in MUDs and I was really impressed! I'm excited to get this squared away on my RPi!

Re: Halp Raspberry Pi Linux Babby

Posted: Fri Aug 31, 2018 2:50 pm
by keneanung
It looks like libzip-dev is not available from the repository, but it's relatively easy to compile yourself. You can follow the instructions on for that.

The missing lua-sql-sqlite3 can be ignored in this step and replaced by libsqlite3-dev. You'll need to do "luarocks install luasql-sqlite3" additionally afterwards, though (just like you install the UTF-8 library that way).

Note: While I have 2 raspi's at home, none is currently set up as a dev machine and as such the hints I can give are not tested.

Re: Halp Raspberry Pi Linux Babby

Posted: Tue Sep 18, 2018 11:18 pm
by SlySven
Compiling Mudlet on an RPi itself is going to be, um, unpleasant IMHO.

Unlike TinTin++ (which is in the C language) Mudlet uses C++ and the codebase itself is a whole order of magnitude more work for a compiler/linker to put together as an executable file - the memory requirements will exceed what the RPi has and when your swap-space is a couple of hundred MB on a (HD)SD memory card you will probably find it takes a couple of days to compile it if it is even possible.

Cross-compiling is going to get you out of that hole - but it not something that we have spent any time looking at; sadly the person who does the packaging of Mudlet for the Debian distribution {from which the main Raspbian distribution is derived (I am not sure what the RetroPi distribution uses)} has been put on the back foot by some of the changes to Mudlet in the last year or so. Until the issues have been resolved I am not sure when that distribution's version is going to get a later version than the 3.0.0~rc7iota version that is currently offered - so even the Raspbian people who would be doing exactly this sort of thing (cross-compiling for the RPi3 architecture) only have really old code to work on... :ugeek:

Re: Halp Raspberry Pi Linux Babby

Posted: Wed Sep 19, 2018 5:23 am
by Vadi
I believe the latest version there is 3.7.