Search found 94 matches

by keneanung
Thu Jun 09, 2016 8:15 pm
Forum: Mudlet Mapper
Topic: (mapping script) Mudlet Mapper script for Achaea/IREs
Replies: 241
Views: 119326

Re: (mapping script) Mudlet Mapper script for Achaea/IREs

Hrm... This looks good, so either mudlet or the mapper has a bug or you are using it wrong, but I can't see how. I'll point the Achaean mapper here when I get hold of him... About the crowdmap: You basically export the map and others can download and use the map. Achaea's crowdmap is hosted in a way...
by keneanung
Thu Jun 09, 2016 11:25 am
Forum: Mudlet Mapper
Topic: (mapping script) Mudlet Mapper script for Achaea/IREs
Replies: 241
Views: 119326

Re: (mapping script) Mudlet Mapper script for Achaea/IREs

@missari: Also if you are planning to publish this map as a crowdmap similar to Achaea, we should probably hurry with the setup (just gimme a ping about it). I just read that new github pages will be required to use HTTPS after 15th June and Mudlet does not support HTTPS before 3.0 (which is not yet...
by keneanung
Thu Jun 09, 2016 7:29 am
Forum: Mudlet Mapper
Topic: (mapping script) Mudlet Mapper script for Achaea/IREs
Replies: 241
Views: 119326

Re: (mapping script) Mudlet Mapper script for Achaea/IREs

Multiple possibilities here, but overall I'd check the gmcp output of the game for the rooms. If you can paste the output of "lua display(gmcp.Room.Info)" (should be an alias) here, it might help to find the cause.
by keneanung
Thu Jun 02, 2016 9:00 pm
Forum: Mudlet Mapper
Topic: (mapping script) Mudlet Mapper script for Achaea/IREs
Replies: 241
Views: 119326

Re: (mapping script) Mudlet Mapper script for Achaea/IREs

This is because the map must be provided by the IRE and the game. If it's not updated, the mapper doesn't have any chance to know.

The only game with a crowdmap (player maintained map) is for Achaea right now, but it is far better maintained than the official map provided by Achaea itself.
by keneanung
Tue Jan 13, 2015 7:53 pm
Forum: Whatever
Topic: Lua 5.3 released
Replies: 4
Views: 2868

Re: Lua 5.3 released

I haven't looked too deeply, but I didn't find too much that was incompatible. It was merely a suggestion and a hope this were things we could work around :P
by keneanung
Tue Jan 13, 2015 9:45 am
Forum: Whatever
Topic: Lua 5.3 released
Replies: 4
Views: 2868

Lua 5.3 released

The new lua 5.3 also has a UTF-8 support library. Maybe this would be a reason to upgrade?

http://www.lua.org/news.html
by keneanung
Thu Dec 18, 2014 5:53 pm
Forum: Help Forum
Topic: Background ANSI colors not displaying.
Replies: 8
Views: 1534

Re: Background ANSI colors not displaying.

The comments to ProtocolOutput herehttps://github.com/zusuk/LuminariMUD/blob/ab03e3ed9fb75079ddd9823005c8dd957f68f2d0/src/protocol.h suggest that Luminari already supports fg/bg for xterm mode. Not sure about indexed colours though.
by keneanung
Thu Dec 18, 2014 4:28 pm
Forum: Help Forum
Topic: Background ANSI colors not displaying.
Replies: 8
Views: 1534

Re: Background ANSI colors not displaying.

I honestly fail to see how using the inverse differs from setting the foreground/background colours appropriately. ETA: by "setting the foreground/background appropriately" I mean using the ANSI tags for FG/BG colours: 30-37 for indexed foreground colours and 38 for xterm256 foreground as well as 40...
by keneanung
Thu Dec 18, 2014 4:16 pm
Forum: Help Forum
Topic: Background ANSI colors not displaying.
Replies: 8
Views: 1534

Re: Background ANSI colors not displaying.

It is currently not implemented. But have a look at https://github.com/Mudlet/Mudlet/pull/223 where strikeThrough support is currently being added. After rereading that PR and the comments I revise my statement of "probably won't in near future", but that is something the core developers need to dec...
by keneanung
Thu Dec 18, 2014 4:01 pm
Forum: Help Forum
Topic: Background ANSI colors not displaying.
Replies: 8
Views: 1534

Re: Background ANSI colors not displaying.

I had a look at this in both the mudlet and the luminari code on github but I was not able to check the live communication with wireshark yet. Fom what I gathered from the source te @= tag is supposed to inverse the colors (ANSI tag 7). Mudlet does currently not support that tag and probably won't i...