Search found 43 matches

by eraldo
Mon Aug 17, 2009 12:19 pm
Forum: Help Forum
Topic: setTextFormat > red not working
Replies: 2
Views: 1555

setTextFormat > red not working

When I set setTextFormat to:
setTextFormat("ChatWindow",0,0,0,255,0,255,0,0,0);
I get the same as:
setTextFormat("ChatWindow",0,0,0,0,0,255,0,0,0);
I have made other similar tests ...all pointing towards "red" beeing ignored!

Is this the case only on my setup?
Any ideas how to solve this?
by eraldo
Mon Aug 17, 2009 12:14 pm
Forum: Help Forum
Topic: Color Trigger
Replies: 2
Views: 1604

Color Trigger

I have mad a Color-Trigger which triggers on: fg > bright white bg > cyan The trigger works fine, but... it matches no no matter if the text is bold or not I would only want it to capture the not bold white (fg) lines or make a it a filter and then further check for boldness... Any idea how this can...
by eraldo
Mon Aug 17, 2009 11:15 am
Forum: Howtos, FAQs and Tips & Tricks
Topic: deselect problem fix
Replies: 2
Views: 1797

deselect problem fix

I get an error when using deselect() ERROR:Lua error:[string "function Trigger15()..."]:4: attempt to call global 'deselect' (a nil value) My workaround: I made the following script: function deselect() selectString("",1) end This overried the default deselect() function... Works as intended now! Ho...
by eraldo
Mon Aug 17, 2009 11:09 am
Forum: Help Forum
Topic: coloring Problem
Replies: 2
Views: 1420

coloring Problem

I color my exits.. and as soon as I color something else after that... the last exit turns that same color (instead of staying in ExitColor) I color all my exits like this: selectString( matches[1], 1 ) fg( ExitColor ) deselect() I got an error in the debug buffer telling me: ERROR:Lua error:[string...
by eraldo
Mon Aug 17, 2009 10:45 am
Forum: Help Forum
Topic: strange degree symbol
Replies: 5
Views: 1988

Re: strange degree symbol

I have found out that I get this symbol if the MUD sends a 'beep" to me! I desabled beeping in my mudds settings... now the symbol is gone. It would still be nice if this feature would work as intended... but for me this is very low priority. If there are further questions ... don't hesitate to ask....
by eraldo
Sun Aug 16, 2009 3:44 pm
Forum: Help Forum
Topic: strange degree symbol
Replies: 5
Views: 1988

strange degree symbol

Whenever someone 'tells' me something in my mud I get a degree symbol before the actual line. The programmers of my mud have checked and told me that it id not sent to me.. and it has to be some client side problem. Sample Text from the MUD: (reconstructed) As it is now: °Leo Lachgummi redet zu Dir:...
by eraldo
Thu Aug 13, 2009 7:58 pm
Forum: Help Forum
Topic: where to save player infos
Replies: 1
Views: 1044

where to save player infos

I save my data in normal single variables: e.g. hp = matches[2] etc But I have seen that some people do it like this: player.stats.tp = matches[2] I am not quite sure of the pros and cons of those 2 methods but I like the idea alot! Plus I was wondering if I could make the player part variable: <pla...
by eraldo
Thu Aug 13, 2009 3:53 pm
Forum: Help Forum
Topic: Equivalent zMud onConnect
Replies: 12
Views: 3663

Re: Equivalent zMud onConnect

Sounds like a great solution :)
by eraldo
Fri Jul 17, 2009 4:54 pm
Forum: Help Forum
Topic: multiline prompt
Replies: 0
Views: 1941

multiline prompt

I have a prompt that looks like this: >[Eraldo,S69,399/399, ,93/93, ,123/123, ,2628, ,5957231] >[80,an,aus,an,be,2, , , , , ,22,17.07.09,18:39:05,01:29:24] > In my MUD I can set the prompt to any thing/form I like. This made me want to put a lot of information inside it, so I set my prompt like this...
by eraldo
Fri Jul 17, 2009 4:37 pm
Forum: Help Forum
Topic: umlauts
Replies: 1
Views: 1479

umlauts

U need to change every "ä","ö" and "ü" to "ae", "oe" and "ue" before it gets sent to the mud. I tried to make an alias for each with pattern "ä" and substitute "ae". However this replaces the entire input and "ae" is sent to the mud. What would be the recommended way to change pieces of my input bef...