Search found 66 matches

by chrio
Mon Jul 30, 2018 4:08 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

Thanks for the links it was good reading. I took look at it and would like to discuss it some more. I found more on wikipedia https://en.wikipedia.org/wiki/ANSI_escape_code#SGR_(Select_Graphic_Rendition)_parameters (mostly the same info, but more selective). Oh, those sequences do look wrong: Screen...
by chrio
Mon Jul 30, 2018 2:46 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

Sorry for the late response, I've been on vacation over the weekend.
Vadi wrote:
Fri Jul 27, 2018 4:42 pm
Would you mind reporting the issue to them about the invalid ANSI?
Sure, I'll try to get in touch with them.
by chrio
Thu Jul 26, 2018 2:13 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

I am just taking a look at this and will see what I can find - I expect some recent improvement I made to the ANSI SGR code handling has made things much better except for a corner case that is now being hit... I tested with mudlet 3.0.1 downloaded from the archives and it had the same problem. Per...
by chrio
Wed Jul 25, 2018 4:06 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

Still the same behaviour in windows aswell i'm afraid.
by chrio
Wed Jul 25, 2018 3:57 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

How do these test builds work for you: https://ci.appveyor.com/api/buildjobs/fiplu7xyqidenowd/artifacts/src%2Fmudlet.zip (windows) https://transfer.sh/rYwRp/Mudlet-3.11.1-testing-PR1840-3086dae-linux-x64.AppImage.tar (linux) The linux version still has the problem. I'll reboot and try the windows o...
by chrio
Wed Jul 25, 2018 3:08 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

So I tested the latest linux version of mudlet (v3.11.1) to see how that handled the problem and it behaved slightly different. On Linux the ansi colours are not displayed at all. On the plus side I get warnings written to the console, hopefully they can provide some insight to the problem. The warn...
by chrio
Tue Jul 24, 2018 8:21 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

Just a small update to my problem:
Not sure if this is useful, but I did some more testing with a new profile and noticed that the very first color sequence works, but then that color gets stuck for the remainder of the buffer, so no more ansi sequences have an effect.
by chrio
Tue Jul 24, 2018 7:41 am
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

Re: ANSI colors not being displayed

Vadi wrote:
Tue Jul 24, 2018 6:51 am
Can you record a Mudlet replay for us to look at? It's the casette bottom-right of the screen.
Sure thing, here is a small one:
24-07-2018#09-31-16.dat
Mudlet replay
(3.79 KiB) Downloaded 91 times
by chrio
Mon Jul 23, 2018 11:14 pm
Forum: Help Forum
Topic: ANSI colors not being displayed
Replies: 18
Views: 2111

ANSI colors not being displayed

Hi All, so I got the urge to try my old mud today and after updating mudlet from 3.0 to the current version I gave it a go. Logging in with my old profile worked as it should, but the ansi colors were not displayed. Checking with another mud client on the same accound did display the colors. I teste...
by chrio
Tue Oct 11, 2016 9:13 pm
Forum: Help Forum
Topic: HALP! Font Size Issue!
Replies: 5
Views: 1911

Re: HALP! Font Size Issue!

Proxy wrote:Thank you very much, chrio!
No problem :)