Search found 50 matches

by kaeus
Sat Dec 28, 2013 11:10 pm
Forum: Help Forum
Topic: Map Behavior
Replies: 8
Views: 1816

Re: Map Behavior

I was literally doing saveMap() in a script that I didn't have attached to any events/functions that just attempted to add special exits. Took me a bit to track it down, but essentially as soon as my scripts loaded, it did a saveMap. The UI in my case is loaded on a sysLoadEvent, so the map window w...
by kaeus
Fri Dec 27, 2013 1:15 pm
Forum: Help Forum
Topic: Map Behavior
Replies: 8
Views: 1816

Re: Map Behavior

The map is being created (in my UI) on the sysLoadEvent, but this particular function was being used to seed special exits, then save the changes to the map.
by kaeus
Fri Dec 27, 2013 4:41 am
Forum: Help Forum
Topic: Map Behavior
Replies: 8
Views: 1816

Re: Map Behavior

Think I found the issue. I had a script that was saving my map as soon as my system loads, so the data that was being downloaded was not able to be added properly.
by kaeus
Fri Dec 27, 2013 12:33 am
Forum: Help Forum
Topic: Map Behavior
Replies: 8
Views: 1816

Re: Map Behavior

Also worth noting, I'm not using the default mudlet mapping scripts, but my own. My scripts fully recognize the rooms, and I can still map around, it is just the display that gets screwed up.
by kaeus
Fri Dec 27, 2013 12:23 am
Forum: Help Forum
Topic: Map Behavior
Replies: 8
Views: 1816

Re: Map Behavior

I can send you a copy of my system and show you what I mean. If you load up a profile with no map and load my system, then load a map, you get a blank map. If you load up Aetolia without it, everything seems fine. I've tried isolating what does it, but I wasn't able to 100% pinpoint it yet.
by kaeus
Thu Dec 26, 2013 8:23 pm
Forum: Help Forum
Topic: Map Behavior
Replies: 8
Views: 1816

Map Behavior

I've been having an issue with my mapper for loading any new map (deleting the map data and redownloading). What I get is essentially an unrenderable map, just a grey screen that causes a segfault in Mudlet when you click. Now I've tested loading a fresh map with/without my system, and as far as I c...
by kaeus
Wed Jul 17, 2013 9:19 pm
Forum: Help Forum
Topic: resetProfile and Registered Event Handlers
Replies: 3
Views: 715

Re: resetProfile and Registered Event Handlers

This will be super awesome. Is the feature to access the path to a specific module going to be available as well in the next release?
by kaeus
Wed Jul 17, 2013 1:44 pm
Forum: Help Forum
Topic: resetProfile and Registered Event Handlers
Replies: 3
Views: 715

resetProfile and Registered Event Handlers

I noticed when using resetProfile, that while it does reset everything, it seems to not apply the registered event handlers again. As a LOT of my setup uses event handlers to capture all the GMCP data, this still requires that I reset Mudlet or go through each of those scripts to re-register the eve...
by kaeus
Sat Jul 13, 2013 3:53 pm
Forum: Help Forum
Topic: Mapper Coloring Issues
Replies: 3
Views: 850

Re: Mapper Coloring Issues

Yep. What I am saying is that the mapper knows about the rooms (I can run all the commands to get room info and whatnot) but visually there is nothing reflected in the mapper window. I am able to do centerview, but there is no actual room that I am in. They just aren't drawn at all.
by kaeus
Thu Jul 11, 2013 4:37 pm
Forum: Help Forum
Topic: Mapper Coloring Issues
Replies: 3
Views: 850

Mapper Coloring Issues

I've seen this happen a couple of times, where the map downloads a new update from the game, yet the new rooms you have end up showing as blank in the map window. They exist in the map, but for some reason are uncolored and basically not even select-able on the map. I can fix this by deleting all my...