[SOLVED] Auto-login problems - GMCP issue?

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby Vadi » Wed Feb 13, 2013 8:44 pm

Then that's certainly not the issue you're experiencing.
User avatar
Vadi
 
Posts: 3840
Joined: Sat Mar 14, 2009 3:13 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby Golem » Wed Feb 13, 2013 8:58 pm

It does seem that the MAC version of mudlet-lua is a bit behind the curve ;)
Just replace the entire folder with the one found here https://github.com/Beliaar/mudlet-lua/archive/master.zip
Golem
 
Posts: 30
Joined: Thu Feb 07, 2013 6:46 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby bluebaleen » Wed Feb 13, 2013 9:17 pm

Golem wrote:It does seem that the MAC version of mudlet-lua is a bit behind the curve ;)
Just replace the entire folder with the one found here https://github.com/Beliaar/mudlet-lua/archive/master.zip


Thanks!
bluebaleen
 
Posts: 48
Joined: Sun Feb 06, 2011 2:00 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby neutrino » Tue Oct 29, 2013 4:10 pm

I've replaced my entire mudlet-lua folder with the one in this git archive but I am still unable to auto-login to my mud... it tries to log in with username "[]myusername" as opposed to the expected "myusername"

Was there ever a definite solution to this? I'm on Mudlet 2.1 on macOSX

Thanks!
neutrino
 
Posts: 4
Joined: Sun Oct 27, 2013 3:54 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby InsanityMG » Wed Oct 30, 2013 12:20 am

I also have this problem on Linux Mint 15, when I type my name username it comes up []username. So I have to type my username twice. Thanks
InsanityMG
 
Posts: 7
Joined: Tue Oct 29, 2013 1:11 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby Vadi » Wed Oct 30, 2013 8:27 am

neutrino wrote:I've replaced my entire mudlet-lua folder with the one in this git archive but I am still unable to auto-login to my mud... it tries to log in with username "[]myusername" as opposed to the expected "myusername"

Was there ever a definite solution to this? I'm on Mudlet 2.1 on macOSX

Thanks!


Are you certain you've replaced it? I'm not sure if that zip contains the fix, but the fix is definitely in the latest mudlet-lua already.
User avatar
Vadi
 
Posts: 3840
Joined: Sat Mar 14, 2009 3:13 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby neutrino » Wed Oct 30, 2013 4:30 pm

Vadi --

Maybe I'm not understanding exactly what I need to do. Here's what I did.

git clone https://github.com/vadi2/mudlet-lua.git mudlet-lua

then, I replaced the folder Contents/Resources/mudlet-lua with the mudlet-lua that I just cloned from git.

Do I have to compile something? Or, re-opening mudlet should automatically source from the replaced folder?

Thanks!
neutrino
 
Posts: 4
Joined: Sun Oct 27, 2013 3:54 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby Vadi » Wed Oct 30, 2013 7:46 pm

Don't need to recompile anything, re-opening Mudlet will re-read the files. I don't quite remember where mudlet-lua is stored within the app package - if that is the single location, then that'd be it.
User avatar
Vadi
 
Posts: 3840
Joined: Sat Mar 14, 2009 3:13 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby neutrino » Thu Oct 31, 2013 12:37 am

Re-opening mudlet doesn't seem to re-read the files. I've only got one mudlet install. Any tips on how to troubleshoot this? Is there somewhere I could put a print statement or something to test if the files are being read correctly?

Thx
neutrino
 
Posts: 4
Joined: Sun Oct 27, 2013 3:54 pm

Re: [SOLVED] Auto-login problems - GMCP issue?

Postby Heiko » Thu Oct 31, 2013 10:26 am

Mudlet-lua is located inside the app bundle. Just edit a file (note that not all files in mudlet-lua are actually being loaded!) and add some function definition of your own. Then call this function to see if it's defined or not.
User avatar
Heiko
Site Admin
 
Posts: 1547
Joined: Wed Mar 11, 2009 6:26 pm

Previous

Return to Help Forum

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 1 guest

cron